SilverWav's Journal

The best is yet to come…

Upgrading to Oneiric 11.10 Beta 1 – propritary Nvidia drivers

with 3 comments

nvidia drivers, second monitor covered by black (Bug #813343 )

This was a little tricky.

I have a Nvidia GeForce 8600 GTS; 1 x Samsung SM226BW (left 1680x 1050); 1 x SMB2430H (right 1920x 1080.).

I was using TwinView via NVIDIA Settings in Natty 11.04 OK prior to the upgrade.

________________________________________

Update : 02.09.2011

I find that to have TwinView work correctly across both screens I need to do this:

The NVIDIA Settings Screen Dance

Enable TwinView, apply and click OK on the invisible dialogue box.

Set Clone and Apply then Cancel.

Note: Both screens now are enabled (but both showing the same view).

Move the right screen to the left or vice versa and apply.

Note: Both screen now allow windows to be moved from one to another.

Move the right screen back to the left and apply.

All working correctly now :-)

Oh and you may want to have a look at this.

________________________________________

Update : 08.09.2011

The latest update has fixed this issue, NVIDIA Settings with TwinView now works fine. :-)

________________________________________

Update : 10.09.2011

Tested again, NVIDIA Settings with TwinView still need to do the The NVIDIA Settings Screen Dance :-(

Advertisements

Written by SilverWav

September 1, 2011 at 5:04 am

Posted in Feature

Tagged with , , , , ,

3 Responses

Subscribe to comments with RSS.

  1. > The latest update has fixed this issue, NVIDIA Settings with TwinView now works fine. :-)

    Which version exactly?
    Which kerne?

    Could you please commit your solution to:
    https://bugs.launchpad.net/ubuntu/+source/unity/+bug/813343

    Greets Axel

    Axel

    September 9, 2011 at 7:00 pm

    • Linux 3.0.0-10-generic #16-Ubuntu SMP Fri Sep 2 18:32:04 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

      NVIDIA Driver Version:280.13 (nvidia-current)
      Server Vendor Version:1.10.2.902 (11002902)

      SilverWav

      September 9, 2011 at 8:54 pm

  2. TwinView was giving me problems since I updated to 11.10, but after this “clone-move left-move right” trick, all is working fine. Thank you!

    Berny Cantos

    November 7, 2011 at 9:18 am


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: